How To Create and Serve WebP Images to Speed Up Your

Having trouble deploying to netlify

Is there anyway I could get some help with why this will not deploy and is getting an error? I took out personal info obviously.
6:03:21 PM: Build ready to start 6:03:23 PM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d 6:03:23 PM: build-image tag: v3.3.20 6:03:23 PM: buildbot version: be8ecf2af866e16fa4301cc5c14de2ccbbb21cf4 6:03:23 PM: Fetching cached dependencies 6:03:23 PM: Starting to download cache of 254.8KB 6:03:23 PM: Finished downloading cache in 70.698045ms 6:03:23 PM: Starting to extract cache 6:03:23 PM: Failed to fetch cache, continuing with build 6:03:23 PM: Starting to prepare the repo for build 6:03:24 PM: No cached dependencies found. Cloning fresh repo 6:03:24 PM: git clone github user 6:03:25 PM: Preparing Git Reference refs/heads/master 6:03:26 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI 6:03:26 PM: Starting build script 6:03:26 PM: Installing dependencies 6:03:26 PM: Python version set to 2.7 6:03:27 PM: v12.18.0 is already installed. 6:03:28 PM: Now using node v12.18.0 (npm v6.14.4) 6:03:28 PM: Started restoring cached build plugins 6:03:28 PM: Finished restoring cached build plugins 6:03:28 PM: Attempting ruby version 2.7.1, read from environment 6:03:29 PM: Using ruby version 2.7.1 6:03:29 PM: Using PHP version 5.6 6:03:30 PM: 5.2 is already installed. 6:03:30 PM: Using Swift version 5.2 6:03:30 PM: Started restoring cached node modules 6:03:30 PM: Finished restoring cached node modules 6:03:30 PM: Installing NPM modules using NPM version 6.14.4 6:04:15 PM: > [email protected] install /opt/build/repo/node_modules/sharp 6:04:15 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy) 6:04:15 PM: info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.8.1/libvips-8.8.1-linux-x64.tar.gz 6:04:18 PM: > [email protected] install /opt/build/repo/node_modules/node-sass 6:04:18 PM: > node scripts/install.js 6:04:18 PM: Downloading binary from https://github.com/sass/node-sass/releases/download/v4.14.1/linux-x64-72_binding.node 6:04:18 PM: Download complete 6:04:18 PM: Binary saved to /opt/build/repo/node_modules/node-sass/vendolinux-x64-72/binding.node 6:04:19 PM: Caching binary to /opt/buildhome/.npm/node-sass/4.14.1/linux-x64-72_binding.node 6:04:19 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-circle/node_modules/core-js 6:04:19 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:19 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-fisheye/node_modules/core-js 6:04:19 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:19 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-shadow/node_modules/core-js 6:04:19 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:19 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-threshold/node_modules/core-js 6:04:19 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:19 PM: > [email protected] postinstall /opt/build/repo/node_modules/core-js 6:04:19 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:19 PM: > [email protected] postinstall /opt/build/repo/node_modules/core-js-pure 6:04:19 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:20 PM: > [email protected] postinstall /opt/build/repo/node_modules/potrace/node_modules/core-js 6:04:20 PM: > node -e "try{require('./postinstall')}catch(e){}" 6:04:21 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby-recipes/node_modules/gatsby-telemetry 6:04:21 PM: > node src/postinstall.js || true 6:04:21 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby-telemetry 6:04:21 PM: > node src/postinstall.js || true 6:04:21 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/node_modules/gatsby-telemetry 6:04:21 PM: > node src/postinstall.js || true 6:04:21 PM: > [email protected] postinstall /opt/build/repo/node_modules/cwebp-bin 6:04:21 PM: > node lib/install.js 6:04:22 PM: :heavy_check_mark: cwebp pre-build test passed successfully 6:04:22 PM: > [email protected] postinstall /opt/build/repo/node_modules/mozjpeg 6:04:22 PM: > node lib/install.js 6:04:22 PM: :heavy_check_mark: mozjpeg pre-build test passed successfully 6:04:22 PM: > [email protected] postinstall /opt/build/repo/node_modules/pngquant-bin 6:04:22 PM: > node lib/install.js 6:04:23 PM: :heavy_check_mark: pngquant pre-build test passed successfully 6:04:23 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli 6:04:23 PM: > node scripts/postinstall.js 6:04:23 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby 6:04:23 PM: > node scripts/postinstall.js 6:04:23 PM: > [email protected] postinstall /opt/build/repo/node_modules/node-sass 6:04:23 PM: > node scripts/build.js 6:04:23 PM: Binary found at /opt/build/repo/node_modules/node-sass/vendolinux-x64-72/binding.node 6:04:23 PM: Testing binary 6:04:23 PM: Binary is fine 6:04:26 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/watchpack/node_modules/fsevents): 6:04:26 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:04:26 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 6:04:26 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:04:26 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/chokidanode_modules/fsevents): 6:04:26 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:04:26 PM: added 2415 packages from 1245 contributors and audited 2489 packages in 55.244s 6:04:28 PM: 110 packages are looking for funding 6:04:28 PM: run npm fund for details 6:04:28 PM: found 18 low severity vulnerabilities 6:04:28 PM: run npm audit fix to fix them, or npm audit for details 6:04:28 PM: NPM modules installed 6:04:28 PM: Started restoring cached go cache 6:04:28 PM: Finished restoring cached go cache 6:04:28 PM: go version go1.14.4 linux/amd64 6:04:28 PM: go version go1.14.4 linux/amd64 6:04:28 PM: Installing missing commands 6:04:28 PM: Verify run directory 6:04:29 PM: 6:04:29 PM: ┌─────────────────────────────┐ 6:04:29 PM: │ Netlify Build │ 6:04:29 PM: └─────────────────────────────┘ 6:04:29 PM: 6:04:29 PM: ❯ Version 6:04:29 PM: @netlify/build 3.0.1 6:04:29 PM: 6:04:29 PM: ❯ Flags 6:04:29 PM: deployId: Id 6:04:29 PM: mode: buildbot 6:04:29 PM: 6:04:29 PM: ❯ Current directory 6:04:29 PM: /opt/build/repo 6:04:29 PM: 6:04:29 PM: ❯ Config file 6:04:29 PM: No config file was defined: using default values. 6:04:29 PM: 6:04:29 PM: ❯ Context 6:04:29 PM: production 6:04:29 PM: 6:04:29 PM: ┌───────────────────────────────────┐ 6:04:29 PM: │ 1. Build command from Netlify app │ 6:04:29 PM: └───────────────────────────────────┘ 6:04:29 PM: 6:04:29 PM: $ gatsby build 6:04:30 PM: /opt/build/repo/node_modules/yoga-layout-prebuilt/yoga-layout/build/Release/nbind.js:53 6:04:30 PM: throw ex; 6:04:30 PM: ^ 6:04:30 PM: Error: Cannot find module 'ink' 6:04:30 PM: Require stack: 6:04:30 PM: - /opt/build/repo/node_modules/ink-box/dist.js 6:04:30 PM: - /opt/build/repo/node_modules/gatsby-recipes/dist/cli.js 6:04:30 PM: - /opt/build/repo/node_modules/gatsby-recipes/dist/index.js 6:04:30 PM: - /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/recipes.js 6:04:30 PM: - /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/create-cli.js 6:04:30 PM: - /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/index.js 6:04:30 PM: - /opt/build/repo/node_modules/gatsby/dist/bin/gatsby.js 6:04:30 PM: at Function.Module._resolveFilename (internal/modules/cjs/loader.js:966:15) 6:04:30 PM: at Function.Module._load (internal/modules/cjs/loader.js:842:27) 6:04:30 PM: at Module.require (internal/modules/cjs/loader.js:1026:19) 6:04:30 PM: at require (internal/modules/cjs/helpers.js:72:18) 6:04:30 PM: at Object. (/opt/build/repo/node_modules/ink-box/dist.js:5:12) 6:04:30 PM: at Module._compile (internal/modules/cjs/loader.js:1138:30) 6:04:30 PM: at Object.Module._extensions..js (internal/modules/cjs/loader.js:1158:10) 6:04:30 PM: at Module.load (internal/modules/cjs/loader.js:986:32) 6:04:30 PM: at Function.Module._load (internal/modules/cjs/loader.js:879:14) 6:04:30 PM: at Module.require (internal/modules/cjs/loader.js:1026:19) { 6:04:30 PM: code: 'MODULE_NOT_FOUND', 6:04:30 PM: requireStack: [ 6:04:30 PM: '/opt/build/repo/node_modules/ink-box/dist.js', 6:04:30 PM: '/opt/build/repo/node_modules/gatsby-recipes/dist/cli.js', 6:04:30 PM: '/opt/build/repo/node_modules/gatsby-recipes/dist/index.js', 6:04:30 PM: '/opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/recipes.js', 6:04:30 PM: '/opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/create-cli.js', 6:04:30 PM: '/opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/index.js', 6:04:30 PM: '/opt/build/repo/node_modules/gatsby/dist/bin/gatsby.js' 6:04:30 PM: ] 6:04:30 PM: } 6:04:30 PM: 6:04:30 PM: ┌─────────────────────────────┐ 6:04:30 PM: │ "build.command" failed │ 6:04:30 PM: └─────────────────────────────┘ 6:04:30 PM: 6:04:30 PM: Error message 6:04:30 PM: Command failed with exit code 7: gatsby build 6:04:30 PM: 6:04:30 PM: Error location 6:04:30 PM: In Build command from Netlify app: 6:04:30 PM: gatsby build 6:04:30 PM: 6:04:30 PM: Resolved config 6:04:30 PM: build: 6:04:30 PM: command: gatsby build 6:04:30 PM: commandOrigin: ui 6:04:30 PM: environment: 6:04:30 PM: - ADSENSE_ID 6:04:30 PM: - GATSBY_BUZZSPROUT_API_KEY 6:04:30 PM: - GATSBY_MAILCHIMP_AUDIENCE_ID 6:04:30 PM: - GATSBY_PODCAST_NUMBER 6:04:30 PM: - GATSBY_PROXY 6:04:30 PM: - NODE_ENV 6:04:30 PM: publish: /opt/build/repo/public 6:04:30 PM: Caching artifacts 6:04:30 PM: Started saving node modules 6:04:30 PM: Finished saving node modules 6:04:30 PM: Started saving build plugins 6:04:30 PM: Finished saving build plugins 6:04:30 PM: Started saving pip cache 6:04:30 PM: Finished saving pip cache 6:04:30 PM: Started saving emacs cask dependencies 6:04:30 PM: Finished saving emacs cask dependencies 6:04:30 PM: Started saving maven dependencies 6:04:31 PM: Finished saving maven dependencies 6:04:31 PM: Started saving boot dependencies 6:04:31 PM: Finished saving boot dependencies 6:04:31 PM: Started saving go dependencies 6:04:31 PM: Finished saving go dependencies 6:04:33 PM: Error running command: Build script returned non-zero exit code: 1 6:04:33 PM: Failing build: Failed to build site 6:04:33 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1 6:04:33 PM: Finished processing build request in 1m10.018686427s
submitted by Blabbers01 to gatsbyjs [link] [comments]

Gatsby builds only failing on Netlify

Hello, I am building a reasonably complex site that pulls some data from git submodules and combines a bunch of data to ultimately pipe it into Gatsby. The issue is that I can get the builds to work absolutely fine on 2 separate Linux machines with different distros (Debian and Ubuntu), different Node versions (10.16 and 10.17), but somehow my builds are always broken on Netlify's server. Does anyone know what I could do?
Repo : https://github.com/30-seconds/30-seconds-web/tree/production (building from production branch)
Netlify log : https://app.netlify.com/sites/hopeful-lovelace-4f6a00/deploys/5dd95d0ac2bced000806a25f
Full log copy:
6:23:38 PM: Build ready to start 6:23:45 PM: build-image version: 9e0f207a27642d0115b1ca97cd5e8cebbe492f63 6:23:45 PM: build-image tag: v3.3.2 6:23:45 PM: buildbot version: a2bab682ae0761baa4d123ebd00c57be933655dc 6:23:45 PM: Fetching cached dependencies 6:23:45 PM: Failed to fetch cache, continuing with build 6:23:45 PM: Starting to prepare the repo for build 6:23:45 PM: No cached dependencies found. Cloning fresh repo 6:23:45 PM: git clone https://github.com/30-seconds/30-seconds-web 6:23:46 PM: Preparing Git Reference refs/heads/production 6:23:58 PM: Found netlify.toml. Overriding site configuration 6:23:58 PM: Starting build script 6:23:58 PM: Installing dependencies 6:23:59 PM: Downloading and installing node v10.17.0... 6:24:00 PM: Downloading https://nodejs.org/dist/v10.17.0/node-v10.17.0-linux-x64.tar.xz... 6:24:00 PM: #################### 6:24:00 PM: ########## 42.9% 6:24:00 PM: ################################## 6:24:00 PM: ###################################### 100.0% 6:24:00 PM: Computing checksum with sha256sum 6:24:00 PM: Checksums matched! 6:24:03 PM: Now using node v10.17.0 (npm v6.11.3) 6:24:03 PM: Attempting ruby version 2.6.2, read from environment 6:24:05 PM: Using ruby version 2.6.2 6:24:05 PM: Using PHP version 5.6 6:24:05 PM: Started restoring cached node modules 6:24:05 PM: Finished restoring cached node modules 6:24:05 PM: Installing NPM modules using NPM version 6.11.3 6:24:59 PM: > [email protected] install /opt/build/repo/node_modules/sharp 6:24:59 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy) 6:24:59 PM: info 6:24:59 PM: sharp 6:24:59 PM: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.8.1/libvips-8.8.1-linux-x64.tar.gz 6:25:01 PM: > [email protected] install /opt/build/repo/node_modules/node-sass 6:25:01 PM: > node scripts/install.js 6:25:02 PM: Downloading binary from https://github.com/sass/node-sass/releases/download/v4.12.0/linux-x64-64_binding.node 6:25:02 PM: Download complete 6:25:02 PM: Binary saved to /opt/build/repo/node_modules/node-sass/vendolinux-x64-64/binding.node 6:25:02 PM: Caching binary to /opt/buildhome/.npm/node-sass/4.12.0/linux-x64-64_binding.node 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@babel/polyfill/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@gatsbyjs/relay-compilenode_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/bmp/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/core/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/custom/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/gif/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/jpeg/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-blit/node_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:03 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:03 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:03 PM: > https://opencollective.com/core-js 6:25:03 PM: > https://www.patreon.com/zloirock 6:25:03 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:03 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-blunode_modules/core-js 6:25:03 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-colonode_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-contain/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-covenode_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-crop/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-displace/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-dithenode_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-flip/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-gaussian/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-invert/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-mask/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:04 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:04 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:04 PM: > https://opencollective.com/core-js 6:25:04 PM: > https://www.patreon.com/zloirock 6:25:04 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:04 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-normalize/node_modules/core-js 6:25:04 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-print/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-resize/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-rotate/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugin-scale/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/plugins/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/png/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/tiff/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/types/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/@jimp/utils/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:05 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:05 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:05 PM: > https://opencollective.com/core-js 6:25:05 PM: > https://www.patreon.com/zloirock 6:25:05 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:05 PM: > [email protected] postinstall /opt/build/repo/node_modules/babel-runtime/node_modules/core-js 6:25:05 PM: > node scripts/postinstall || echo "ignore" 6:25:06 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:06 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:06 PM: > https://opencollective.com/core-js 6:25:06 PM: > https://www.patreon.com/zloirock 6:25:06 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/core-js 6:25:06 PM: > node scripts/postinstall || echo "ignore" 6:25:06 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:06 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:06 PM: > https://opencollective.com/core-js 6:25:06 PM: > https://www.patreon.com/zloirock 6:25:06 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/core-js-pure 6:25:06 PM: > node scripts/postinstall || echo "ignore" 6:25:06 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:06 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:06 PM: > https://opencollective.com/core-js 6:25:06 PM: > https://www.patreon.com/zloirock 6:25:06 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby/node_modules/core-js 6:25:06 PM: > node scripts/postinstall || echo "ignore" 6:25:06 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:06 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:06 PM: > https://opencollective.com/core-js 6:25:06 PM: > https://www.patreon.com/zloirock 6:25:06 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/jimp/node_modules/core-js 6:25:06 PM: > node scripts/postinstall || echo "ignore" 6:25:06 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:06 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:06 PM: > https://opencollective.com/core-js 6:25:06 PM: > https://www.patreon.com/zloirock 6:25:06 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/relay-runtime/node_modules/core-js 6:25:06 PM: > node scripts/postinstall || echo "ignore" 6:25:06 PM: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library! 6:25:06 PM: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 6:25:06 PM: > https://opencollective.com/core-js 6:25:06 PM: > https://www.patreon.com/zloirock 6:25:06 PM: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -) 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby-telemetry 6:25:06 PM: > node src/postinstall.js 6:25:06 PM: > [email protected] postinstall /opt/build/repo/node_modules/cwebp-bin 6:25:06 PM: > node lib/install.js 6:25:07 PM: ✔ cwebp pre-build test passed successfully 6:25:07 PM: > [email protected] postinstall /opt/build/repo/node_modules/mozjpeg 6:25:07 PM: > node lib/install.js 6:25:07 PM: ✔ mozjpeg pre-build test passed successfully 6:25:07 PM: > [email protected] postinstall /opt/build/repo/node_modules/pngquant-bin 6:25:07 PM: > node lib/install.js 6:25:08 PM: ✔ pngquant pre-build test passed successfully 6:25:08 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli 6:25:08 PM: > node scripts/postinstall.js 6:25:08 PM: > [email protected]15.22 postinstall /opt/build/repo/node_modules/gatsby 6:25:08 PM: > node scripts/postinstall.js 6:25:08 PM: > [email protected] postinstall /opt/build/repo/node_modules/node-sass 6:25:08 PM: > node scripts/build.js 6:25:08 PM: Binary found at /opt/build/repo/node_modules/node-sass/vendolinux-x64-64/binding.node 6:25:08 PM: Testing binary 6:25:09 PM: Binary is fine 6:25:14 PM: npm 6:25:14 PM: WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 6:25:14 PM: npm WARN 6:25:14 PM: notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:25:14 PM: npm 6:25:14 PM: WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/gatsby/node_modules/fsevents): 6:25:14 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:25:14 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/gatsby-source-filesystem/node_modules/fsevents): 6:25:14 PM: npm 6:25:14 PM: WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:25:14 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/gatsby-page-utils/node_modules/fsevents): 6:25:14 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 6:25:14 PM: added 2736 packages from 1524 contributors and audited 969117 packages in 68.086s 6:25:14 PM: found 1 low severity vulnerability 6:25:14 PM: run `npm audit fix` to fix them, or `npm audit` for details 6:25:14 PM: NPM modules installed 6:25:15 PM: Started restoring cached go cache 6:25:15 PM: Finished restoring cached go cache 6:25:15 PM: unset GOOS; 6:25:15 PM: unset GOARCH; 6:25:15 PM: export GOROOT='/opt/buildhome/.gimme/versions/go1.12.linux.amd64'; 6:25:15 PM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}"; 6:25:15 PM: go version >&2; 6:25:15 PM: export GIMME_ENV='/opt/buildhome/.gimme/env/go1.12.linux.amd64.env'; 6:25:15 PM: go version go1.12 linux/amd64 6:25:15 PM: Installing missing commands 6:25:15 PM: Verify run directory 6:25:15 PM: Executing user command: npm run build 6:25:15 PM: > [email protected] prebuild /opt/build/repo 6:25:15 PM: > ./src/jobs/prepare_env.sh PRODUCTION; ./src/jobs/fetch_content_sources.sh; ./src/jobs/prepare_cache_key.sh 6:25:15 PM: Preparing environment... 6:25:15 PM: Fetching content sources started... 6:25:16 PM: Submodule path 'content/sources/30code': checked out 'ccfee9a80f67a907de34b7af812b5c83db5617a5' 6:25:17 PM: Fetching content sources complete 6:25:17 PM: Generating cache key... 6:25:17 PM: > [email protected] build /opt/build/repo 6:25:17 PM: > NODE_PATH=src npx --node-arg '-r esm' gatsby build 6:25:25 PM: success open and validate gatsby-configs — 0.226 6:25:30 PM: success parse requirables 6:25:30 PM: success parse reducers 6:25:30 PM: success parse resolvers 6:25:30 PM: success parse templates 6:25:30 PM: success parse queries 6:25:30 PM: success load plugins — 5.581 6:25:30 PM: success onPreInit — 0.037 6:25:30 PM: success delete html and css files from previous builds — 0.045 6:25:30 PM: success initialize cache — 0.043 6:25:31 PM: success copy gatsby files — 0.178 6:25:31 PM: success onPreBootstrap — 0.057 6:25:34 PM: success source and transform nodes — 3.226 6:25:34 PM: success Add explicit types — 0.044 6:25:34 PM: success Add inferred types — 0.322 6:25:35 PM: success Processing types — 0.198 6:25:35 PM: error Snippet.html provided incorrect OutputType: 'Object({ resolve: [function resolve] })' 6:25:35 PM: Snippet.html provided incorrect OutputType: 'Object({ resolve: [function resolve] })' 6:25:35 PM: See our docs page for more info on this error: https://gatsby.dev/issue-how-to 6:25:35 PM: 6:25:35 PM: Error: Snippet.html provided incorrect OutputType: 'Object({ resolve: [functio n resolve] })' 6:25:35 PM: 6:25:35 PM: - TypeMapper.js:294 TypeMapper.convertOutputFieldConfig 6:25:35 PM: [repo]/[graphql-compose]/lib/TypeMapper.js:294:15 6:25:35 PM: 6:25:35 PM: - configAsThunk.js:19 resolveOutputConfigAsThunk 6:25:35 PM: [repo]/[graphql-compose]/lib/utils/configAsThunk.js:19:41 6:25:35 PM: 6:25:35 PM: - ObjectTypeComposer.js:300 ObjectTypeComposer.getFieldConfig 6:25:35 PM: [repo]/[graphql-compose]/lib/ObjectTypeComposer.js:300:58 6:25:35 PM: 6:25:35 PM: - ObjectTypeComposer.js:304 ObjectTypeComposer.getFieldType 6:25:35 PM: [repo]/[graphql-compose]/lib/ObjectTypeComposer.js:304:17 6:25:35 PM: 6:25:35 PM: - SchemaComposer.js:144 tc.getFieldNames.forEach.fieldName 6:25:35 PM: [repo]/[graphql-compose]/lib/SchemaComposer.js:144:28 6:25:35 PM: 6:25:35 PM: - Array.forEach 6:25:35 PM: 6:25:35 PM: - SchemaComposer.js:143 SchemaComposer.removeEmptyTypes 6:25:35 PM: [repo]/[graphql-compose]/lib/SchemaComposer.js:143:24 6:25:35 PM: 6:25:35 PM: - SchemaComposer.js:154 tc.getFieldNames.forEach.fieldName 6:25:35 PM: [repo]/[graphql-compose]/lib/SchemaComposer.js:154:18 6:25:35 PM: 6:25:35 PM: - Array.forEach 6:25:35 PM: 6:25:35 PM: - SchemaComposer.js:143 SchemaComposer.removeEmptyTypes 6:25:35 PM: [repo]/[graphql-compose]/lib/SchemaComposer.js:143:24 6:25:35 PM: 6:25:35 PM: - SchemaComposer.js:103 SchemaComposer.buildSchema 6:25:35 PM: [repo]/[graphql-compose]/lib/SchemaComposer.js:103:12 6:25:35 PM: 6:25:35 PM: - schema.js:94 buildSchema 6:25:35 PM: [repo]/[gatsby]/dist/schema/schema.js:94:33 6:25:35 PM: 6:25:35 PM: 6:25:35 PM: npm 6:25:35 PM: ERR! code 6:25:35 PM: ELIFECYCLE 6:25:35 PM: npm 6:25:35 PM: ERR! errno 1 6:25:35 PM: npm 6:25:35 PM: ERR! [email protected] build: `NODE_PATH=src npx --node-arg '-r esm' gatsby build` 6:25:35 PM: npm ERR! 6:25:35 PM: Exit status 1 6:25:35 PM: npm 6:25:35 PM: ERR! 6:25:35 PM: npm ERR! 6:25:35 PM: Failed at the [email protected] build script. 6:25:35 PM: npm 6:25:35 PM: ERR! This is probably not a problem with npm. There is likely additional logging output above. 6:25:35 PM: npm 6:25:35 PM: ERR! A complete log of this run can be found in: 6:25:35 PM: npm ERR! 6:25:35 PM: /opt/buildhome/.npm/_logs/2019-11-23T16_25_35_400Z-debug.log 6:25:35 PM: Skipping functions preparation step: no functions directory set 6:25:35 PM: Caching artifacts 6:25:35 PM: Started saving node modules 6:25:35 PM: Finished saving node modules 6:25:35 PM: Started saving pip cache 6:25:35 PM: Finished saving pip cache 6:25:35 PM: Started saving emacs cask dependencies 6:25:35 PM: Finished saving emacs cask dependencies 6:25:35 PM: Started saving maven dependencies 6:25:35 PM: Finished saving maven dependencies 6:25:35 PM: Started saving boot dependencies 6:25:35 PM: Finished saving boot dependencies 6:25:35 PM: Started saving go dependencies 6:25:35 PM: Finished saving go dependencies 6:25:38 PM: Error running command: Build script returned non-zero exit code: 1 6:25:38 PM: Failing build: Failed to build site 6:25:38 PM: failed during stage 'building site': Build script returned non-zero exit code: 1 6:25:38 PM: Finished processing build request in 1m53.099978476s 
submitted by angelos_chalaris to gatsbyjs [link] [comments]

Help: Netlify Deploy Fails on Gatsby Build

Solved!

Edit 3: it was a stupid simple problem in the end. Added a longer explanation on the Stack Overflow post, but I had an environment variable (ENV=production) set in the Netlify UI that was preventing devDependencies from installing... :(
Edit 2: Just made the repo Public. Here's the branch/PR I'm working on: https://github.com/heyspacetime/spacetime-gatsby/pull/58
Edit 1: Posting this to StackOverflow as well: https://stackoverflow.com/questions/56102455/gatsby-build-fails-on-netlify-deploy

I haven't touched my Gatsby site in two months. So, when I ran updates and added new content and deployed I ran into a breaking error on Netlify build.
Tried many things and spent too many hours on it already. Originally I was using only npm. After banging on that for a while I switched to yarn (in this branch) as was suggested on some online threads. Getting a different error message now with yarn, but still no luck with the deploy to Netlify.
This is probably something stupid simple. And I know I've had deploy/build issues before and fixed them, but... I'm at a loss at this point...
Help me Reddit, you are my only hope

Deploy Error While Using NPM

``` 2:09:26 PM: Build ready to start 2:09:30 PM: build-image version: f628a20a84a12e8a036199dfa9e2a64f8c90870a 2:09:30 PM: build-image tag: v2.8.1 2:09:30 PM: buildbot version: c8334ba7cb0aa1d6e5824dfaae470274a6132dde 2:09:30 PM: Fetching cached dependencies 2:09:30 PM: Starting to download cache of 255.1KB 2:09:30 PM: Finished downloading cache in 100.859398ms 2:09:30 PM: Starting to extract cache 2:09:30 PM: Failed to fetch cache, continuing with build 2:09:30 PM: Starting to prepare the repo for build 2:09:30 PM: No cached dependencies found. Cloning fresh repo 2:09:30 PM: git clone [email protected]:heyspacetime/spacetime-gatsby 2:09:33 PM: Preparing Git Reference pull/57/head 2:09:34 PM: Found netlify.toml. Overriding site configuration 2:09:34 PM: Starting build script 2:09:34 PM: Installing dependencies 2:09:35 PM: Downloading and installing node v8.16.0... 2:09:35 PM: Downloading https://nodejs.org/dist/v8.16.0/node-v8.16.0-linux-x64.tar.xz... 2:09:35 PM: 0.9% 2:09:35 PM:
2:09:35 PM: 26.8% 2:09:36 PM:
2:09:36 PM: 79.0% 2:09:36 PM:
2:09:36 PM: ##################################### 100.0% 2:09:36 PM: Computing checksum with sha256sum 2:09:36 PM: Checksums matched! 2:09:38 PM: Now using node v8.16.0 (npm v6.4.1) 2:09:38 PM: Attempting ruby version 2.3.6, read from environment 2:09:39 PM: Using ruby version 2.3.6 2:09:40 PM: Using PHP version 5.6 2:09:40 PM: Started restoring cached node modules 2:09:40 PM: Finished restoring cached node modules 2:09:40 PM: Installing NPM modules using NPM version 6.4.1 2:10:26 PM: > [email protected] install /opt/build/repo/node_modules/sharp 2:10:26 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy) 2:10:26 PM: info 2:10:26 PM: sharp 2:10:26 PM: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.7.4/libvips-8.7.4-linux-x64.tar.gz 2:10:28 PM: > [email protected] install /opt/build/repo/node_modules/phantomjs-prebuilt 2:10:28 PM: > node install.js 2:10:29 PM: PhantomJS not found on PATH 2:10:29 PM: Downloading https://github.com/Medium/phantomjs/releases/download/v2.1.1/phantomjs-2.1.1-linux-x86_64.tar.bz2 2:10:29 PM: Saving to /opt/buildhome/tmp/phantomjs/phantomjs-2.1.1-linux-x86_64.tar.bz2 2:10:29 PM: Receiving... 2:10:29 PM: Received 22866K total. 2:10:30 PM: Extracting tar contents (via spawned process) 2:10:33 PM: Removing /opt/build/repo/node_modules/phantomjs-prebuilt/lib/phantom 2:10:33 PM: Copying extracted folder /opt/buildhome/tmp/phantomjs/phantomjs-2.1.1-linux-x86_64.tar.bz2-extract-1557429030319/phantomjs-2.1.1-linux-x86_64 -> /opt/build/repo/node_modules/phantomjs-prebuilt/lib/phantom 2:10:33 PM: Writing location.js file 2:10:33 PM: Done. Phantomjs binary available at /opt/build/repo/node_modules/phantomjs-prebuilt/lib/phantom/bin/phantomjs 2:10:34 PM: > [email protected] postinstall /opt/build/repo/node_modules/cwebp-bin 2:10:34 PM: > node lib/install.js 2:10:35 PM: ✔ cwebp pre-build test passed successfully 2:10:35 PM: > [email protected] postinstall /opt/build/repo/node_modules/mozjpeg 2:10:35 PM: > node lib/install.js 2:10:35 PM: ✔ mozjpeg pre-build test passed successfully 2:10:35 PM: > [email protected] postinstall /opt/build/repo/node_modules/pngquant-bin 2:10:35 PM: > node lib/install.js 2:10:36 PM: ✔ pngquant pre-build test passed successfully 2:10:36 PM: > [email protected] postinstall /opt/build/repo/node_modules/gatsby-telemetry 2:10:36 PM: > node src/postinstall.js 2:10:41 PM: npm WARN optional 2:10:41 PM: SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents): 2:10:41 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"}) 2:10:41 PM: added 2406 packages from 1701 contributors and audited 48740 packages in 59.969s 2:10:41 PM: found 6 vulnerabilities (1 low, 5 high) 2:10:41 PM: run npm audit fix to fix them, or npm audit for details 2:10:41 PM: NPM modules installed 2:10:41 PM: Started restoring cached go cache 2:10:41 PM: Finished restoring cached go cache 2:10:41 PM: Installing Go version 1.10 2:10:47 PM: unset GOOS; 2:10:47 PM: unset GOARCH; 2:10:47 PM: export GOROOT='/opt/buildhome/.gimme_cache/versions/go1.10.linux.amd64'; 2:10:47 PM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.10.linux.amd64/bin:${PATH}"; 2:10:47 PM: go version >&2; 2:10:47 PM: export GIMME_ENV="/opt/buildhome/.gimme_cache/env/go1.10.linux.amd64.env" 2:10:47 PM: go version go1.10 linux/amd64 2:10:47 PM: Installing missing commands 2:10:47 PM: Verify run directory 2:10:47 PM: Executing user command: npm run build 2:10:48 PM: > [email protected] build /opt/build/repo 2:10:48 PM: > gatsby build 2:10:49 PM: error gatsby build 2:10:49 PM: Build a Gatsby project. 2:10:49 PM: Options: 2:10:49 PM: --verbose Turn on verbose output [boolean] [default: false] 2:10:49 PM: --no-color, --no-colors Turn off the color in output [boolean] [default: false] 2:10:49 PM: --prefix-paths Build site with link paths prefixed (set pathPrefix in your gatsby-config.js). [boolean] [default: false] 2:10:49 PM: --no-uglify Build site without uglifying JS bundles (for debugging). [boolean] [default: false] 2:10:49 PM: --open-tracing-config-file Tracer configuration file (OpenTracing compatible). See https://gatsby.dev/tracing [string] 2:10:49 PM: -h, --help Show help [boolean] 2:10:49 PM: -v, --version Show version number [boolean] 2:10:49 PM: error There was a problem loading the local build command. Gatsby may not be installed. Perhaps you need to run "npm install"? 2:10:49 PM: 2:10:49 PM: Error: Cannot find module 'webpack/lib/RequestShortener' 2:10:49 PM: 2:10:49 PM: - v8-compile-cache.js:159 require 2:10:49 PM: [repo]/[v8-compile-cache]/v8-compile-cache.js:159:20 2:10:49 PM: 2:10:49 PM: - extractWebpackError.js:4 Object. 2:10:49 PM: [repo]/[@pieh]/friendly-errors-webpack-plugin/src/core/extractWebpackError.j s:4:26 2:10:49 PM: 2:10:49 PM: - v8-compile-cache.js:178 Module._compile 2:10:49 PM: [repo]/[v8-compile-cache]/v8-compile-cache.js:178:30 2:10:49 PM: 2:10:49 PM: 2:10:49 PM: npm 2:10:49 PM: ERR! code ELIFECYCLE 2:10:49 PM: npm 2:10:49 PM: ERR! 2:10:49 PM: errno 1 2:10:49 PM: npm ERR! 2:10:49 PM: [email protected] build: gatsby build 2:10:49 PM: npm 2:10:49 PM: ERR! Exit status 1 2:10:49 PM: npm ERR! 2:10:49 PM: npm ERR! Failed at the [email protected] build script. 2:10:49 PM: npm 2:10:49 PM: ERR! This is probably not a problem with npm. There is likely additional logging output above. 2:10:49 PM: npm 2:10:49 PM: ERR! A complete log of this run can be found in: 2:10:49 PM: npm ERR! 2:10:49 PM: /opt/buildhome/.npm/_logs/2019-05-09T19_10_49_396Z-debug.log 2:10:49 PM: Skipping functions preparation step: no functions directory set 2:10:49 PM: Caching artifacts 2:10:49 PM: Started saving node modules 2:10:49 PM: Finished saving node modules 2:10:49 PM: Started saving pip cache 2:10:49 PM: Finished saving pip cache 2:10:49 PM: Started saving emacs cask dependencies 2:10:49 PM: Finished saving emacs cask dependencies 2:10:49 PM: Started saving maven dependencies 2:10:49 PM: Finished saving maven dependencies 2:10:49 PM: Started saving boot dependencies 2:10:49 PM: Finished saving boot dependencies 2:10:49 PM: Started saving go dependencies 2:10:51 PM: Finished saving go dependencies 2:10:53 PM: Error running command: Build script returned non-zero exit code: 1 2:10:53 PM: Failing build: Failed to build site 2:10:53 PM: failed during stage 'building site': Build script returned non-zero exit code: 1 2:10:53 PM: Finished processing build request in 1m23.436145288s 2:10:53 PM: Shutting down logging, 0 messages pending ```
https://user-images.githubusercontent.com/4457883/57573341-d1731600-73eb-11e9-82f8-dbadbd8e3ed4.png

Deploy Error After Switching to Yarn

``` 10:42:15 PM: Build ready to start 10:42:18 PM: build-image version: 8e315e54bc4032a32e73290be556cde4f8348c12 10:42:18 PM: build-image tag: v2.8.2 10:42:18 PM: buildbot version: 1c5d5da2a8a19e94f07a53f82f5c9b010bad1249 10:42:18 PM: Fetching cached dependencies 10:42:18 PM: Failed to fetch cache, continuing with build 10:42:18 PM: Starting to prepare the repo for build 10:42:18 PM: No cached dependencies found. Cloning fresh repo 10:42:18 PM: git clone [email protected]:heyspacetime/spacetime-gatsby 10:42:22 PM: Preparing Git Reference pull/58/head 10:42:22 PM: Found netlify.toml. Overriding site configuration 10:42:22 PM: Starting build script 10:42:22 PM: Installing dependencies 10:42:23 PM: Downloading and installing node v8.16.0... 10:42:23 PM: Downloading https://nodejs.org/dist/v8.16.0/node-v8.16.0-linux-x64.tar.xz... 10:42:24 PM: 0.3% 10:42:24 PM:
10:42:24 PM: 16.3% 10:42:24 PM:
10:42:24 PM: 81.6% 10:42:24 PM:
10:42:24 PM: ################################# 100.0% 10:42:24 PM: Computing checksum with sha256sum 10:42:24 PM: Checksums matched! 10:42:26 PM: Now using node v8.16.0 (npm v6.4.1) 10:42:26 PM: Attempting ruby version 2.3.6, read from environment 10:42:27 PM: Using ruby version 2.3.6 10:42:28 PM: Using PHP version 5.6 10:42:28 PM: Started restoring cached node modules 10:42:28 PM: Finished restoring cached node modules 10:42:28 PM: Started restoring cached yarn cache 10:42:28 PM: Finished restoring cached yarn cache 10:42:28 PM: Installing yarn at version 1.5.1 10:42:28 PM: Installing Yarn! 10:42:28 PM: > Downloading tarball... 10:42:28 PM: [1/2]: https://yarnpkg.com/downloads/1.5.1/yar 10:42:28 PM: n-v1.5.1.tar.gz /tmp/yarn.tar.gz.unnZulZpgP 10:42:28 PM: % Total % Recei 10:42:28 PM: ved % Xferd Average Speed Time Time Time Curr 10:42:28 PM: ent 10:42:28 PM: Dload Upload Total Spent 10:42:28 PM: Left Speed 10:42:28 PM: 0 10:42:28 PM: 0 0 0 0 0 0 0 --:--:-- --:- 10:42:28 PM: -:-- --:--:-- 0 10:42:28 PM: 100 91 100 91 0 0 511 10:42:28 PM: 0 --:--:-- --:--:-- --:--:-- 514 10:42:28 PM: 0 0 0 608 0 0 1591 0 --: 10:42:28 PM: --:-- --:--:-- --:--:-- 1591 10:42:28 PM: 100 914k 100 914k 0 0 1226k 0 --:--:-- --:- 10:42:28 PM: -:-- --:--:-- 1226k 10:42:28 PM: [2/2]: https://yarnpkg.co 10:42:28 PM: m/downloads/1.5.1/yarn-v1.5.1.tar.gz.asc /tmp/yarn.tar.gz.unnZ 10:42:28 PM: ulZpgP.asc 10:42:29 PM: 100 95 100 95 0 0 2061 0 --:--:- 10:42:29 PM: - --:--:-- --:--:-- 2061 10:42:29 PM: 0 0 0 612 0 0 3939 10:42:29 PM: 0 --:--:-- --:--:-- --:--:-- 3939 10:42:29 PM: 0 832 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 10:42:29 PM: 100 832 100 832 0 0 3750 10:42:29 PM: 0 --:--:-- --:--:-- --:--:-- 812k 10:42:29 PM: > Verifying integrity... 10:42:29 PM: gpg: Signature made Mon 26 Feb 2018 07:01:19 PM UTC using RSA key ID B6FF4DE3 10:42:29 PM: gpg: Good signature from "Yarn Packaging [email protected]" 10:42:29 PM: gpg: Note: This key has expired! 10:42:29 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310 10:42:29 PM: Subkey fingerprint: E219 30C4 D0A4 AA46 1858 1F7A E074 D16E B6FF 4DE3 10:42:29 PM: > GPG signature looks good 10:42:29 PM: > Extracting to ~/.yarn... 10:42:29 PM: > Adding to $PATH... 10:42:29 PM: > We've added the following to your /opt/buildhome/.profile 10:42:29 PM: > If this isn't the profile of your current shell then please add the following to your correct profile: 10:42:29 PM: export PATH="$HOME/.yarn/bin:$HOME/.config/yarn/global/node_modules/.bin:$PATH" 10:42:29 PM: 10:42:30 PM: > Successfully installed Yarn 1.5.1! Please open another terminal where the yarn command will now be available. 10:42:30 PM: Installing NPM modules using Yarn version 1.5.1 10:42:31 PM: yarn install v1.5.1 10:42:31 PM: [1/4] Resolving packages... 10:42:33 PM: [2/4] Fetching packages... 10:42:55 PM: info [email protected]: The platform "linux" is incompatible with this module. 10:42:55 PM: info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation. 10:42:55 PM: [3/4] Linking dependencies... 10:42:55 PM: warning " > [email protected]" has incorrect peer dependency "[email protected]". 10:42:55 PM: warning "gatsby > pnp-webpack-plugin > [email protected]" has unmet peer dependency "[email protected]*". 10:42:55 PM: warning "gatsby-plugin-transition-link > babel-preset-gatsby-package > @babel/[email protected]" has unmet peer dependency "@babel/[email protected]7.0.0-0". 10:42:55 PM: warning "gatsby-plugin-transition-link > babel-preset-gatsby-package > @babel/[email protected]" has unmet peer dependency "@babel/[email protected]7.0.0-0". 10:42:55 PM: warning "gatsby-plugin-transition-link > babel-preset-gatsby-package > @babel/plugin-proposal-optional-chaining > @babel/[email protected]" has unmet peer dependency "@babel/[email protected]7.0.0-0". 10:43:05 PM: [4/4] Building fresh packages... 10:43:12 PM: success Saved lockfile. 10:43:12 PM: Done in 41.23s. 10:43:12 PM: NPM modules installed using Yarn 10:43:12 PM: Started restoring cached go cache 10:43:12 PM: Finished restoring cached go cache 10:43:12 PM: Installing Go version 1.10 10:43:18 PM: unset GOOS; 10:43:18 PM: unset GOARCH; 10:43:18 PM: export GOROOT='/opt/buildhome/.gimme_cache/versions/go1.10.linux.amd64'; 10:43:18 PM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.10.linux.amd64/bin:${PATH}"; 10:43:18 PM: go version >&2; 10:43:18 PM: export GIMME_ENV="/opt/buildhome/.gimme_cache/env/go1.10.linux.amd64.env" 10:43:18 PM: go version go1.10 linux/amd64 10:43:18 PM: Installing missing commands 10:43:18 PM: Verify run directory 10:43:18 PM: Executing user command: npm run build 10:43:18 PM: > [email protected] build /opt/build/repo 10:43:18 PM: > gatsby build 10:43:20 PM: success open and validate gatsby-configs — 0.011 s 10:43:21 PM: success load plugins — 1.030 s 10:43:21 PM: success onPreInit — 0.118 s 10:43:21 PM: success delete html and css files from previous builds — 0.005 s 10:43:21 PM: success initialize cache — 0.008 s 10:43:21 PM: success copy gatsby files — 0.022 s 10:43:21 PM: success onPreBootstrap — 0.004 s 10:43:22 PM: success source and transform nodes — 0.413 s 10:43:22 PM: success building schema — 0.226 s 10:43:22 PM: success createPages — 0.018 s 10:43:22 PM: success createPagesStatefully — 0.072 s 10:43:22 PM: success onPreExtractQueries — 0.002 s 10:43:22 PM: success update schema — 0.024 s 10:43:22 PM: success extract queries from components — 0.078 s 10:43:22 PM: success run static queries — 0.001 s 10:43:22 PM: success run page queries — 0.019 s — 20/20 1114.65 queries/second 10:43:22 PM: success write out page data — 0.006 s 10:43:22 PM: success write out redirect data — 0.001 s 10:43:23 PM: success Build manifest and related icons — 0.776 s 10:43:23 PM: success onPostBootstrap — 0.778 s 10:43:23 PM: info bootstrap finished - 5.200 s 10:43:42 PM: error Generating JavaScript bundles failed 10:43:42 PM: 10:43:42 PM: Error: ./src/assets/stylesheets/styles.scss 10:43:42 PM: Module build failed (from ./node_modules/gatsby/node_modules/mini-css-extract- plugin/dist/loader.js): 10:43:42 PM: ModuleBuildError: Module build failed (from ./node_modules/sass-loadelib/loa der.js): 10:43:42 PM: Error: ENOENT: no such file or directory, scandir '/opt/build/repo/node_module s/node-sass/vendor' 10:43:42 PM: at Object.fs.readdirSync (fs.js:904:18) 10:43:42 PM: at Object.getInstalledBinaries (/opt/build/repo/node_modules/node-sass/lib /extensions.js:131:13) 10:43:42 PM: at foundBinariesList (/opt/build/repo/node_modules/node-sass/lib/errors.js :20:15) 10:43:42 PM: at foundBinaries (/opt/build/repo/node_modules/node-sass/lib/errors.js:15: 5) 10:43:42 PM: at Object.module.exports.missingBinary (/opt/build/repo/node_modules/node- sass/lib/errors.js:45:5) 10:43:42 PM: at module.exports (/opt/build/repo/node_modules/node-sass/lib/binding.js:1 5:30) 10:43:42 PM: at Object. (/opt/build/repo/node_modules/node-sass/lib/index.js :14:35) 10:43:42 PM: at Module._compile (/opt/build/repo/node_modules/v8-compile-cache/v8-compi le-cache.js:178:30) 10:43:42 PM: at Object.Module._extensions..js (module.js:664:10) 10:43:42 PM: at Module.load (module.js:566:32) 10:43:42 PM: at tryModuleLoad (module.js:506:12) 10:43:42 PM: at Function.Module._load (module.js:498:3) 10:43:42 PM: at Module.require (module.js:597:17) 10:43:42 PM: at require (/opt/build/repo/node_modules/v8-compile-cache/v8-compile-cache .js:159:20) 10:43:42 PM: at Object.sassLoader (/opt/build/repo/node_modules/sass-loadelib/loader. js:46:72) 10:43:42 PM: at runLoaders (/opt/build/repo/node_modules/gatsby/node_modules/webpack/li b/NormalModule.js:301:20) 10:43:42 PM: at /opt/build/repo/node_modules/loader-runnelib/LoaderRunner.js:367:11 10:43:42 PM: at /opt/build/repo/node_modules/loader-runnelib/LoaderRunner.js:233:18 10:43:42 PM: at runSyncOrAsync (/opt/build/repo/node_modules/loader-runnelib/LoaderRu nner.js:143:3) 10:43:42 PM: at iterateNormalLoaders (/opt/build/repo/node_modules/loader-runnelib/Lo aderRunner.js:232:2) 10:43:42 PM: at Array. (/opt/build/repo/node_modules/loader-runnelib/Loade rRunner.js:205:4) 10:43:42 PM: at Storage.finished (/opt/build/repo/node_modules/enhanced-resolve/lib/Cac hedInputFileSystem.js:43:16) 10:43:42 PM: at provider (/opt/build/repo/node_modules/enhanced-resolve/lib/CachedInput FileSystem.js:79:9) 10:43:42 PM: at /opt/build/repo/node_modules/graceful-fs/graceful-fs.js:90:16 10:43:42 PM: at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:511:3) 10:43:42 PM: @ ./src/components/layout.js 6:0-43 10:43:42 PM: @ ./src/pages/services/technical-seo.js 10:43:42 PM: @ ./.cache/async-requires.js 10:43:42 PM: @ ./.cache/production-app.js 10:43:42 PM: 10:43:42 PM: npm 10:43:42 PM: ERR! code ELIFECYCLE 10:43:42 PM: npm ERR! 10:43:42 PM: errno 1 10:43:42 PM: npm 10:43:42 PM: ERR! [email protected] build: gatsby build 10:43:42 PM: npm ERR! Exit status 1 10:43:42 PM: npm ERR! 10:43:42 PM: npm ERR! Failed at the [email protected] build script. 10:43:42 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above. 10:43:43 PM: npm 10:43:43 PM: ERR! A complete log of this run can be found in: 10:43:43 PM: npm ERR! /opt/buildhome/.npm/_logs/2019-05-11T03_43_42_997Z-debug.log 10:43:43 PM: Skipping functions preparation step: no functions directory set 10:43:43 PM: Caching artifacts 10:43:43 PM: Started saving node modules 10:43:43 PM: Finished saving node modules 10:43:43 PM: Started saving yarn cache 10:43:43 PM: Finished saving yarn cache 10:43:43 PM: Started saving pip cache 10:43:43 PM: Finished saving pip cache 10:43:43 PM: Started saving emacs cask dependencies 10:43:43 PM: Finished saving emacs cask dependencies 10:43:43 PM: Started saving maven dependencies 10:43:43 PM: Finished saving maven dependencies 10:43:43 PM: Started saving boot dependencies 10:43:43 PM: Finished saving boot dependencies 10:43:43 PM: Started saving go dependencies 10:43:44 PM: Finished saving go dependencies 10:43:46 PM: Error running command: Build script returned non-zero exit code: 1 10:43:46 PM: Failing build: Failed to build site 10:43:46 PM: failed during stage 'building site': Build script returned non-zero exit code: 1 10:43:46 PM: Finished processing build request in 1m28.562451072s 10:43:46 PM: Shutting down logging, 0 messages pending ```
https://user-images.githubusercontent.com/4457883/57573280-f61abe00-73ea-11e9-8aa9-673f32572202.png
submitted by sylvezine to gatsbyjs [link] [comments]

eman mohamed - YouTube Изображения в формате WEBP optimizar imágenes al formato webp gratis, mediante código. Come and check me out How to use WebP images today

In this tutorial, we have covered basic techniques for working with WebP images. We have explained how to use cwebp to convert files, as well as two options to serve these images to users: HTML5’s <picture> element and Apache’s mod_rewrite. In order to customize the scripts from this tutorial, you can look at some of these resources: WebP Convert. Convert JPEG & PNG to WebP with PHP. This library enables you to do webp conversion with PHP. It supports an abundance of methods for converting and automatically selects the most capable of these that is available on the system. The binary path that you will configure usually is something like this: /usr/local/bin/cwebp Configuration options. All configuration options for this module can be found in the System Configuration under Web and then Webp images. The options allow you to enable the 2 WebP conversion methods. cwebp [options] input.{jpg,png,tiff,webp,bmp} -o output.webp. As you can see, all options must be determined before the input file. The simplest use. cwebp image.png -o output_file.webp. You can modify it a bit by adding the -q option. It means level of quality. -q must be between 0-100. Higher value means higher quality. grunt-webp-compress: Download the cwebp binary for your system. grunt-cwebp: Convert JPEG and PNG to WebP with grunt task. cwebp-bin: cwebp bin-wrapper that makes it available as a local dependency. gulp-webp: Convert images to WebP. imagemin-webp: WebP plugin for imagemin. node-webp: Node.js wrapper for cwebp and dwebp.

[index] [16567] [43771] [918] [16094] [43535] [46634] [24185] [469] [15059] [24652]

eman mohamed - YouTube

•Criptic.gg on ig. Bass Boosted Mix 🔈 Car Music Mix 2020 🔈 Best EDM, Bounce, Electro House 24/7 Arcadia Boosted 1,301 watching Live now Эксперименты с форматом webp. Поддержка в браузерах. Реальный коэффициент сжатия. Утилита cwebp и её флаги. Для оптимизации изображений можно использовать optipng, pngcrush, TruePNG, gifsicle, jpegtran, cwebp Следующий этап: беремся за за ... In this video we look at how to use WebP images today even though not all browsers provide support. We use the Picture tag to specify multiple image sources of which one is WebP. This allows us to ... Sign in to like videos, comment, and subscribe. Sign in. Watch Queue Queue